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If you are used to Microsoft Office 2003, the new Office 2010 screens initially will look and feel very 
different.  In addition, you’ll notice changes to how Windows works because that, too, has been 
upgraded (from Windows XP to Windows 7).  This guide is designed to help you get up to speed fast 
with these changes.  At the end, we’ve listed further resources you can use to address any remaining 
questions or concerns you may have. 
 

KEY CHANGES & SHORTCUTS IN WINDOWS 7 
 
The main changes in Windows 7 are in the Start button features, how the Task Bar works at the 
bottom of the screen (with the Start button at one end and the time at the other), and in Windows 
Explorer. 
 

The Start Menu 

When you click the Start button, you’ll notice that the menu has 
been cleaned up, displaying only the principle Microsoft Office 
applications.  You can find other software by clicking on All 
Programs and exploring the menus.  However, the quickest way to 
find other programs is: 
 

1. Open the Start menu and click into the Search programs 
and files box. 

2. Start typing the name of the application you require.  (Try 
calculator or SPSS.)  As you type, options appear. 

3. When you see the option you need, click on it to open it. 
The program opens and the program icon appears in the 
Task Bar in the centre of a illuminated box. 

4. Next time you open the Start menu, you’ll see this program 
in the list.  Right click on the program name and, if you want it to remain in the list, select Pin 
to Start Menu.  Alternately, select Remove from this list. 

 

Working with Windows Explorer 

Rest your mouse pointer on the icon next to the Start button in the Task Bar.  (The 
icon name appears.)  Click it to open Windows Explorer.  Think of this as your filing 
cabinet; all your files on your computer and in the LSE network can be found, 
previewed, copied, moved or deleted from here. 
 
Three ways to find files: 
 

1. Use the Navigation Pane on the right to select the drive and folder you want to view.  (If 
needed, make the panel wider by clicking and dragging the bar so that you can see the letter 
names of each of the drives listed. 

Click on the arrow in front of a drive or folder to open or close the next level.  Click on the 
drive or folder icon to view its contents in the next panel. 

Click to turn on the Preview Pane icon in the upper right corner of the screen. A new panel 
opens along the right side of the screen. 

Select any file in any folder.  A preview of the file appears in the preview pane. 

2. Select a folder you want to search, and type part of the file name into the Search box in the 
upper right corner just under the Close icon. 

3. Drag frequently used (or frequently lost!) folders onto the Favorites heading at the top of the 
Navigation Bar. 
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Restoring the Desktop to your Favorites list 
 
It is quite useful to be able to save files to your Desktop.  However, 
after your computer is upgraded, the Desktop may not be displayed 
in your Windows Explorer Favorites list.  To restore the Desktop to 
your Favorites list: 
 

1. Open Windows Explorer.  
2. Right-click on Favorites and Restore Favorite Links.  The 

Desktop appears at the top of the Favorites list. 
 
‘Pinning’ Programs & Files to the Task Bar 
 
Windows 7 includes a great time saving feature called ‘pinning’ files 
and programs to the Task Bar.  It is useful for files and programs 
that you use frequently.  (By default, Windows Explorer is already 
‘pinned’ to your Task Bar.)  This allows you to open files, and the program used to edit them, directly 
from the Task Bar at the bottom of the screen.    
 

1. First, the program must be pinned to the task bar.  To do so, open the program, right click on 
its icon in the taskbar and select Pin this program to the taskbar.  (Henceforth this icon will 
remain on the Task Bar even when the program is closed.  You can use the icon to reopen the 
program at any time.) 

2. Open Windows Explorer and find the file you want to pin to the taskbar. 
3. Click and drag the file’s icon onto the relevant program icon in the taskbar.  When a box 

appears saying Pin to Word 2010 (or the relevant program), release the mouse button. 

 

4. To open both the file and the program, right click on the relevant program icon in the Task Bar 
and select the file name. 

 

The Show Desktop Button 
 
In Windows XP, there was a handy little icon next to the Start button that minimised all windows and 
displayed the desktop.  In Windows 7 someone has cleverly disguised this button as a chrome bar, 
and placed it at the far right end of the Task Bar, next to 
the time.   
 
NOTE: If you rest your mouse pointer on this button, the desktop will be previewed and the name of 
the button (Show Desktop) appears.  You must click it to go to the desktop.     
 

KEY CHANGES & NEW FEATURES IN OFFICE 2010 

Although we discuss the changes in Word 2010, these same changes work in exactly the same way in 
the other Office 2010 applications, such as PowerPoint, Excel and Outlook.  Please use this guide as 
an opportunity to try out and become familiar with Office 2010 and Windows 7.   

The Office 2010 Ribbon  
 
Office 2003’s menus and toolbars at the top of the screen have been replaced by a ‘ribbon’.  This 
consists of a set of tabs, each containing icons arranged in named clusters.  While Word is used to 
illustrate these features here, this basic structure, and the way it is used, is the same across all the 
Office 2010 programs.   
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1. Click on each of the tabs to explore what they contain and to find the commands you use most 

often.  Generally, the Home tab has the most commonly used icons in the program you are in.  
(The Home tab in Word is displayed above.) 

2. Many new, useful icons have been added. 
Rest the mouse pointer on an icon to find its 
name and an explanation (and often a help 
link for more information). 

 

 

 
 

3.  Click on the arrow (called the dialog box launcher) to the right of some icon cluster names to 
open the relevant Office 2003 dialogue box, with all the commands arranged as in 2003.   

 

4. Right clicking and shortcut keys generally work as before.  To find additional shortcut keys for the 
ribbons, press ALT.  Shortcut letters will appear on the ribbon.  Press the relevant key to activate 
the command. 

5. The File tab contains most of the commands previously found in the Office 2003 File menu, such 
as Save As, Open and Print.   

a. By default, the File tab opens to the Info section.  The file itself is shown in miniature in 
the upper right corner of the window, and the file name continues to appear in the Menu 
Bar at the top of the window.  

Click the dialog box 
launcher arrow in the 
Font cluster to open 
the Font dialog box. 

What this icon 
is used for 
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 To return to editing the document, click on any other tab. 

 To view any other File tab section, click on it in the Navigation Pane on the left 
side of the window. 

b. The Recent list displays both recently opened files and folders.  Click the pin to keep a 
document in the list at the top of the window.  Click the pin again to return the document to 
the temporary list at the bottom.  Right-click on a document to remove it from the list. 
(Note: this action does not delete the document; it only removes it from this list.) 

 

c. Selecting the Print heading in the Navigation Pane automatically displays the file in Print 
Preview mode.  Use the Zoom bar icons in the lower right corner of the window to 
increase or decrease the magnification.  (NOTE: the Zoom bar is available as you edit the 
file, too, no matter which ribbon tab you’ve selected.) 
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d. The new Save & Send section provides icons to send your file as an attachment or as a 
PDF.  (Clicking the relevant button automatically opens a new, blank Outlook message 
with the file attached in the relevant format.)  

e. Options enables you to customise the program to suit your personal preferences, offering 
more adjustments than were possible from the Office 2003 Tools | Options menu. 

 

Quick Access Toolbar 

Notice that in the top left corner of every Office 2010 program screen there is a tiny Quick Access 
Toolbar containing the Save, Undo and Redo icons.  Use this to create your own customised toolbar 
with your favourite icons.  (The example here is for PowerPoint, but this feature works in exactly the 
same way in every Office 2010 program.)  You can add icons in any of 3 ways: 

1. Click on the arrow at the right end of the Quick Access Toolbar and select any of the icons listed 
(as shown). 

2. Right click on any icon on any tab in the ribbon and click Add to Quick Access toolbar. 
3. To add any icon and re-order the icons in your Quick Access Toolbar, follow these steps: 

a. Click on the arrow at the right end of the Quick Access Toolbar (as in step 1 above) and 
select More Commands. (The Options dialog box opens.)  
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b. Click on the arrow next to Popular Commands and select All Commands. 
c. Use the scroll bar to move through the huge list of icons available. 
d. Double-click on an icon to add it to your toolbar. (It will appear in the list on the right side 

of the dialogue box.) 
e. Click on an icon in the list on the right, and then use the up or down arrow to change its 

position in the list. 
f. When you are finished, click OK.  (The dialogue box closes and the Quick Access Toolbar 

at the top of the screen is changed as you’ve commanded.) 

 

Finding 2003 Commands in 2010 

Having difficulty finding an icon or command in Office 2010?  Here is how to do so: 

1. In the ribbon, click on the LSE Support tab and use the Find Word 2003 commands in 2010 icon.  
(The same feature is available in Excel and PowerPoint, too.)   

2. Internet Explorer will open to a Microsoft page on the internet.  (You may have to click the Internet 
Explorer icon in the Task Bar at the bottom of your screen to view it.)   

3. Click the Start button on this screen.  (The 2003 window is displayed.) 
4. Click on the icon or menu option you would use in 2003.  (The screen flips to 2010, and highlights 

the tab and icon you need to do the same task in the new version.) 

Unfortunately, we couldn’t add an LSE Support tab to the Outlook ribbon.  However, Microsoft has 
Find 2003 Commands in 2010 links for all its Office applications here: http://office.microsoft.com/en-
us/support/office-ribbon-find-commands-FX101851541.aspx.   

 
 

 Other really useful new features 

1. Built in PDF creation: see the File tab Save & Send option, and the Save As type list. 
2. Live preview of formatting options: the relevant option is previewed when you select content and 

rest the mouse on certain icons, such font or style options. 
3. Greatly enhanced picture editing tools. 
4. Use icon or click/double click tabs to minimise/maximise the ribbon. 
5. Improved chart options and techniques. 
 

Sources of help, training and guidance  

1. Go to www.lse.ac.uk/ITServices/2010Upgrade for links to: 

a. Interactive guides showing where to find any command from Office 2003 in Office 2010: 
select Training & Support, scroll down to How do I… find that command? and click on 
Microsoft’s interactive guides  

b. Microsoft online short video courses 

http://office.microsoft.com/en-us/support/office-ribbon-find-commands-FX101851541.aspx
http://office.microsoft.com/en-us/support/office-ribbon-find-commands-FX101851541.aspx
http://www.lse.ac.uk/ITServices/2010Upgrade
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c. The migration checklist of what to do to prepare your PC for the upgrade 

d. Online demonstrations of how new features work 

e. Sources of further assistance 

2. F1 and the new Help icon   

 

Still can’t find what you need? 

Tell us by sending an email to IT.Training@lse.ac.uk, or  
 
Book a 1-2-1 training session by logging in and opening the Tailored IT Training option here: 
https://apps.lse.ac.uk/training-system/  

mailto:IT.Training@lse.ac.uk
https://apps.lse.ac.uk/training-system/

